Zend Server    Zend Studio    Zend Guard    Zend Framework    Zend Core    お取引全般について    その他

Zend Guard の FAQ

Zend Guard をご検討中によくいただくお問い合わせをまとめました。
イグアスから Zend Guard をご購入いただきますと、ご使用中によくいただくお問い合わせや便利な Tips をお客様向け FAQ ページでご覧いただけます。 項目の例をこのページの最後でご紹介しています

表の凡例
Ver特定の Version のみ該当する場合、その番号を記載します。

Ver 最終
更新
質問回答
- 2015/05 複数のバージョンを同時に使用することはできますか。 下記の2つの条件があります。
・インストール先のディレクトリーをそれぞれ別の場所にする。
・ワークスペースの場所をそれぞれ別の場所にする。
- 2015/11 エンコード・暗号化した PHP スクリプトを実行するために何か必要ですか PHP 実行環境に Zend Guard Loader をインストールする必要があります。
- 2015/11 Zend Guard Loader はどのようにしたらインストールできますか 2つの方法があります。通常は下記のうち1 を使用することをお勧めします。
1)PHP 実行環境を Zend Server で新規に作成します。そのインストール中に Zend Guard Loader も必要なモジュールとして選択します。
2)すでに PHP 実行環境がある場合、zend.com から Zend Guard Loader をダウンロードしてインストールします。
- 2016/03 Zend Guard Loader で不明点がある場合、問い合わせ窓口はどちらですか 1) イグアスから Zend Guard をご購入いただいたみなさまの場合
   ライセンス証書に記載のシリアル番号とともに弊社にお問い合わせください。

2) 暗号化されたアプリケーションの利用者様の場合
   恐れ入りますが、アプリケーションを提供する業者にお問い合わせください。
   業者と連絡が取れない場合、zend.com のフォーラム に類似の事例が報告されていないかご確認ください。
- 2015/11 Zend Guard を購入する場合、Zend Guard Loader もダウンロードが必要ですか いいえ、Zend Guard の購入者が必要とするわけではありません。エンコード・暗号化した PHP スクリプトを実行する場合のみ、Zend Guard Loader が必要です。
例えば、他社がエンコード・暗号化してから販売している PHP アプリケーションを購入した Web サーバー管理者が該当します。
- 2015/07 Zend Guard Loader は、FreeBSD でも使用できますか OpenBSD、FreeBSD のような BSD 系の OS は動作対象外となっております。
- 2016/03 Zend Guard Loader の PowerLinux 版はありますか 恐れ入りますが PowerLinux 板はございません。IBM i, x86 Linux, Windows, Mac OS 版の4種類となります。
6.0 2016/03 Zend Guard Loader for PHP 5.4は、Windows 2012 でも使用できますか 公式にはサポート対象外となります。詳細はお問い合わせください。
- 2015/04 Zend Guard でエンコード・暗号化された PHP スクリプトかどうか確認する方法はありますか Zend Guard Loader API の zend_loader_file_encoded 関数でチェックできます。
Zend Guard でエンコード・暗号化されたファイルの場合、true が返ります。
- 2015/04 エンコード・暗号化した PHP スクリプトとエンコード・暗号化しない PHP スクリプトは混在して使用できますか はい、使用できます。ただし、下記の場合注意が必要です。
詳しくは、ユーザーガイドをご覧ください。
1) 「同一署名のエンコードファイルのみ動作」を設定してエンコード・暗号化した場合
2) 難読化した PHP スクリプトに定義された関数やクラスを難読化していない PHP スクリプトで呼び出す場合

お客様向け FAQ ページでご覧いただける FAQ

  • ライセンスキーを登録しようとしたところ、Unknown exit status recieved from ZendGuard wrapper と表示されます。対応方法を教えてください。